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At Promethean, we support global education communities with the right tools to keep 

classrooms connected and students engaged. We have combined the interactive tools of the 

ActivPanel with our award-winning lesson delivery software to help you create digital 

resources, connect your classrooms and engage with your students no matter where the 

physical classroom takes you. 

Record your lessons 

and share via Google 

Classroom, Microsoft 

Teams, Box or any 

cloud sharing platforms. 

Have students install the 

personal version of 

ActivInspire and share 

activities for offline 

interactions.  

 

Interact with your 

students via live online 

lessons and create 

assignments, playlists, 

quizzes and activities to 

keep students 

connected to their 

learning with any 

device. 

https://support.prometheanworld.com/activinspire-download
https://classflow.com


 

 

 

 

 

 
Preparing Students and Parents for Remote Learning 

 

 

Message: Provide a clear, calm message of why you are providing remote learning, accessing 
materials, expectations and how you will communicate and support both parents and students.  
Remind: Parents and students should be reminded of the district’s acceptable use policy. Post a 
copy in your mobile learning platform. 
Access: Provide or explain how students will access devices. (Either the district will provide, 
personal devices or if public devices are accessible.) 
Internet: Explain how students will connect to the internet on their device. Provide safety tips for 
students on devices. Ex. Lessons will be 15 min. in length, internet safety and digital citizenship.  
Applications: Provide access to applications students will need to view and interact with content. 
Communication: Provide “How To” tips for signing in, accessing resources, connecting to the 
internet, content releases, due dates, how to communicate with the teacher, locating quiz/test 
scores, support guides.  
Demonstrate: Provide videos or live demonstration of how to navigate the mobile environment, 
how to access content, create products, complete course work, quizzes and tests and how to 
submit items. 
Schedule: Live lessons should be performed at the same time on the same set day. (Ex. The live 
math lesson will be every Monday and Wednesday at 9:00 am.) 
 
 

 
 



 

 

 

 

 

Teacher Tips for Creating Remote Resources  

 
 
 

 

 

 

Microlearning: Create smaller learning units, short learning activities and keep resources 
organized in units.  
Weeding: Remove unnecessary information.  
Match Modalities: Showing on-screen animation with narration, audio with reading passages, 
photos to support content or sound files for pronunciations helps to prevent cognitive overload 
and assists students with processing. 
Signaling: Highlight the information that needs to be processed and bold key words to direct the 
learner’s attention. 
Segmenting: Chunk your information to help students process information. Smaller videos (5 
min. or less) break points for information and call out information.  
Design: Support for all screen sizes – Larger text, easy activities and easy navigation of 
resources. Games should be single-screen challenges.  
Assess: Quiz students often to provide them with feedback and test for documentation of student 
understanding.  
Communicate: Post directions and communicate often on your message board. Create office 
hours to provide a time when students know you are available to communicate with them. 
Award: Provide badges, call outs on the message board or emails to students and parents about 
whole class or individual success. 
Anywhere Content: Content should be created/placed in formats that are accessible on all 
mobile devices. Ex. PDFs. Choose a platform that has players for your videos and easy upload of 
content. 
Data Access: Access to student data to evaluate and document understanding.  
Student Products: Provide resources and applications for students to create and submit.  

 

 
 



 

 

 

 

 

Administrator Tips for Remote Learning 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Device Agnostic: Browser access for access to learning content and live instructional sessions. 
Equitable Platforms: All teachers and students have access and support the classroom 
workflow in a mobile environment. 
Data Security: Ensure that your mobile learning platform is iKeepSafe and compliant with the 
Family Educational Rights and Privacy Act (FERPA), Student Online Personal Information 
Protection Act (SOPIPA), and the Children’s Online Privacy Protection Act (COPPA). (ClassFlow 
has no subscription or hidden fees and is FERPA, SOPIPA and COPPA compliant.) 
Data Retrieval: Confirm that your mobile learning platform allows you to retrieve your 
instructional materials and student data. 
Professional Development: Learning needs to be online, self-paced and provide certificates and 
badges. Training materials should be varied and include lesson samples, short “How To” videos, 
online courses for certifications and orientations and getting started manuals. 
Content Materials and Management: Teachers need the ability to access a lesson repository 
and manage the instructional engagement of the content, assessments and the student workflow 
in a controlled environment.  
Accountability: Assessments and student work samples demonstrate student learning and 
understandings. Ensure your mobile learning platform has a variety of ways for teachers to 
assess and gather student work. 
 



 

 

 

 

 

Resources for Content and Professional Development  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Promethean Certified Teacher 

Learn the foundational tools of the Promethean classroom and how to 

integrate these tools into your daily instruction. Showcase your 

proficiency by taking the exam and earning your Promethean Certified 

Teacher badge and certificate.  

learn.prometheanworld.com  

Learn Promethean 

Free on-demand training and teaching resources at your fingertips to 

help you easily get started creating interactive lessons. 

learn.prometheanworld.com 

myPromethean>Resource Library 

Easily preview, download, and open flipcharts in a few clicks. 

mypromethean.com 

ClassFlow>Marketplace 

Save time with ready-made activities. Choose from lessons, 

ActivInspire Flipcharts, PPTs, 3D Objects and more.  

classflow.com 

file:///D:/Desktop%202020/Documents/Content%20Queens/Content%20Materials/Mobile%20Learning/academy.prometheanworld.com
https://learn.prometheanworld.com/
https://blog.prometheanworld.com/learn-promethean/
https://learn.prometheanworld.com/
file:///D:/Desktop%202020/Documents/Content%20Queens/Content%20Materials/Mobile%20Learning/mypromethean.com
https://portal.mypromethean.com/
file:///D:/Desktop%202020/Documents/Content%20Queens/Content%20Materials/Mobile%20Learning/classflow.com
https://classflow.com/


 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Record and Share with ActivInspire 

Record your ActivInspire flipcharts, desktop and 

computer applications to create lesson 

materials to share with your students. 

Examples: 

• Modeling New Skills 

• Digital Storytelling  

• Presenting Content 

• Instructions/Directions for Tasks 

• Science Experiments  

• PE Exercises  

• Navigating the Mobile Environment 

  
 

T 
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P 
 

• State the purpose  
• Get to the point 
• Keep recordings 

short 
• Align recordings with  

activities  

ActivInspire Screen Recorder 

Open ActivInspire – Tools>More Tools>Screen 

Recorder.  

Choose between Full Screen Recorder or Area 

Screen Recorder. 

If you choose Full Screen Recorder, the 

recorder will automatically launch. With Area 

Screen Recorder, drag to create the area you 

wish to record, then click Launch Recorder. 

 

 

 
 

 
 
 
When you are ready to begin, click Record. The Save 
a Recorder File dialog box opens. Choose the location 
you wish to save the file to, enter a name, and click 
Save. 

 

For Windows, recording is indicated by alternating blue 
and red flashing dots. For Mac, recording is indicated 
by a solid blue dot and continues until Pause or Stop is 
pressed. 

 

 

1. Save your recording to  

your computer 

2. Open OneNote 

3. Select Insert>File>Insert 

Attachment>Choose File 

4. Locate your recording  

Share to OneNote 

1. Save your recording to  

your Google Drive 

2. Open Google Classroom 

3. Select Share with 

class>Add>Google Drive 

>Choose File>Add 

4. Assign to Classes   

Share to Google Classroom 



 

 

 

 

 

Polling in ActivInspire 

1. Open ActivInspire. 

2. Select the Express Poll. 

3. Select the Poll Option. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ActivInspire and Live Polling 

Present your flipcharts through any 

telecommunication learning platform such as Skype 

or Google Hangouts and connect students to conduct 

live polling sessions. 

1. Create a ClassFlow account 

2. Select ClassFlow Connect in 

ActivInspire 

3. Sign in with your ClassFlow 

credentials   

ClassFlow 

Connect 
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• Guided Reading Questions 

• Check for Understanding 

• Building Concept Maps 

• Fun Games 

• Use Desktop Annotate 

during live lessons 

 

•  
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• Keep recordings short 

 

 

 

 

 

 

 

 

 

 

 

 

Create and Engage with ClassFlow 

Create Assignments, connect students to lessons, 

quiz and submit student products in an easy online 

environment that provides  

fluid interactions and submissions.  

Examples: 

• Live Lessons 

• Live Polling 

• Assessments 

• Assignments 

• Student Accounts 

• Announcements 

  
 

Create a Student Assignment 

Log into your ClassFlow account. 

Create a Class. 

Upload your resources (Resources>New>File Upload). 

Create an Assignment (Resources>New> 

Assignment>Title>Save). 

 

 

 

 

 

 

Organizing Resources (Add Resources>Select 

Resource>Select). 

Assign (Assign>Choose Class>Deliver). 

 

 

 

 

• Organize lesson 

materials 

• Use rubrics to guide 

students 

• Reward students with 

badges 

• Include assessments 

1. Add ClassFlow app to  

G-Suite 

2. Lessons, Assessments 

and Activities stored in 

Google Drive 

3. Assign via Google 

Classroom 

 Google Classroom  

1. Create assessment  

Resources>New> 

Assessment  

2. Add the assessment to 

your assignments  

Polling/Assessments 
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1. Deliver Lesson 

Resources>Choose 

Lesson>Deliver 

2. Connect Students 

Classflow.com/student 

3. 8 Types of Polling Options 

Live Polling 

1. Choose Class>Drop 

Down 

2. Delivered Polls>Lesson 

3. Review 

View Polling Results 

ClassFlow Classes 

 
Create a Class 

Log into ClassFlow. 

Classes>New>Add a Class. 

Name Your Class>Student Generated. 

 

 

 

 

 

 

 

 

 

 

Enrolling Students 

Log into ClassFlow. 

Classes>Chose Your Class>Roster>Class 

Code>Select Choose. 

Students create their account and use the 

class code to enroll. 

 

 

 

 

 

 

 

 
 

• ClassFlow Marketplace 

• Import ActivInspire 

Flipcharts 

• Deliver Lessons 

• Create badges for 

standards 



 

 

 

 

 

Video Conferencing on the Promethean Elements Series ActivPanel 

 

Install the district approved video conferencing app from the Promethean store that is 

preinstalled on your panel. To install apps from the Google Play Store, select the Unified Menu, 

then tap Locker. 

  

 

 

  

From the Apps tab within the Locker, select Play Store. 

 

 

 

 

 

  

 

 

Locate the video conferencing app you wish to install on your ActivPanel and tap Install. You 

may be prompted to confirm the installation once more. 

 

Installed apps will automatically display within your Locker for easy access. If you have more 

than 15 apps installed, swipe left or right to navigate between pages and locate the newly 

installed app.  

 

 

 

 

 
 



 

 

 

 

 

Video Conferencing with Google Meet  

 

Starting a video conferencing session with Google Meet, you will need to open 

the Google Meet app. Select the Unified Menu, tap Locker and locate the 

Google Meet app, tap to open it and sign into your account. 

 

Starting a new meeting, select either New meeting or Meeting code.  

 

  

 

After the meeting has begun, tap the menu in the top right corner of the screen.  

 

 

Select Present screen from the menu.  

  

  

 

The first time you are using the app you will need to toggle the Allow display over other apps 

option on and tap Back.  

 

 

You are now presenting your ActivPanel screen, anyone who is logged into the same meeting 

will see the ActivPanel screen and any navigation that is made on the ActivPanel. 

 

Tips: 

Sharing Audio: Connect a microphone or webcam with built in microphone to the ActivPanel. 

Side by Side Screen Sharing:  Sharing the instructional space and the ActivPanel at the same 

time. Choose a camera set up (computer with built in camera, webcam, tablet or phone) and 

direct it at the ActivPanel. Launch the application on your computer and join the session as a 

participant from you panel. 

  

 

 

 



 

 

 

 

 

Video Conferencing with Zoom  

 

                           Starting a video conferencing session with Zoom, you will need to open 

                           the Zoom app. Select the Unified Menu, tap Locker and locate the Zoom app, 

                           tap to open it and sign into your account. 

 

Starting a New Meeting, Join, or start a previously scheduled meeting from the Meetings icon at 

the bottom of the screen. 

           

 

  

 

Select Share and Screen from the menu located at the bottom of screen. 

 

 

  

 

The first time you are using the app, you will need to toggle the Allow display over other apps 

option On and tap Back.  

 

 

You are now presenting your ActivPanel screen, anyone who is logged into the same meeting 

will see the ActivPanel screen and any navigation that is made on the ActivPanel. 

 

Tips: 

Sharing Audio: Connect a microphone or webcam with built in microphone to the ActivPanel. 

Side by Side Screen Sharing:  Sharing the instructional space and the ActivPanel at the same 

time. Choose a camera set up (computer with built in camera, webcam, tablet or phone) and 

direct it at the ActivPanel. Launch the application on your computer and join the session as a 

participant from you panel. 

  

Share icon 



 

 

 

 

 

Video Conferencing with Microsoft Teams  

 

Starting a video conferencing session with Microsoft Teams, you will need to 

open the Microsoft Teams app. Select the Unified Menu, tap Locker and locate 

the Microsoft Teams app, tap to open it and sign into your account. 

 

Starting a New Meeting, tap on the Calendar icon located at the bottom of the screen and 

select Join to join a previously scheduled meeting, then tap on Join now.     

  

 

 

To share your screen, tap on More Actions located on the menu bar at the bottom center of the 

screen and tap on Share and Share Screen. 

 

  

 

 

The first time you are using the app, you will need to toggle the Allow display over other apps 

option On, and tap Back.  

 

 

You are now presenting your ActivPanel screen, anyone who is logged into the same meeting 

will see the ActivPanel screen and any navigation that is made on the ActivPanel. 

Tips: 

Sharing Audio: Connect a microphone or webcam with built in microphone to the ActivPanel. 

Side by Side Screen Sharing:  Sharing the instructional space and the ActivPanel at the same 

time. Choose a camera set up (computer with built in camera, webcam, tablet or phone) and 

direct it at the ActivPanel. Launch the application on your computer and join the session as a 

participant from you panel.  


